设为首页 - 加入收藏 - 网站地图 - RSS订阅 村姑网-www.cunguer.com
当前位置:首页 > 网络编程 > PHP > 正文

宝塔面板提示【警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本】怎么办

时间:2020-04-06 23:11:56 来源:村姑网 作者:喜欢安静 阅读: 0 次
导读:出现【警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本】的服务环境:服务器版本:centos 7.2Apache版本:Apache2.2PHP版本:php5.2由于服务器要搭建可可网络验证V9.5版,根据可可官网给出的服务器环境要求,必须要使用zend optimizer版本:v3.3.*,所以php...

出现【警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本】的服务环境:

服务器版本:centos 7.2

Apache版本:Apache2.2

PHP版本:php5.2

由于服务器要搭建可可网络验证V9.5版,根据可可官网给出的服务器环境要求,必须要使用zend optimizer版本:v3.3.*,所以php最高只能用php5.2版的,所以在宝塔面板中只有选择Apache2.2了。手动安装完后,在宝塔面板->软件商店->已安装下面的php5.2那一行有红色的提示文字“ (警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本!)”如下图:

警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本!

经过多次尝试重新安装php5.2(极速模式),无法解决,后来在宝塔论坛上看到说用编译安装,也尝试了,没有用,安装到一半会停止掉。

解决办法:

根据我的需求,我最重要的是要安装php5.2,因为我要使用zend optimizer3.3,所以我尝试不使用Apache,把Apache换成Nginx-1.16,为什么要用1.16?因为是宝塔面板的默认选项,懒得改了,抱着试一试的态度操作的。如果你一定要用Apache的话,个人感觉需要手动搭建环境,换Apache版本,换php安装包等等一个一个尝试,由于本人比较懒,就算了,能满足需求就可以了。

操作步骤:

1、卸载Apache。

2、安装Nginx-1.16

最终,php5.2那一项不再出现“ (警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本!)”这个提示了。下面建立站点看下php环境,上传一个只包含“phpinfo()”这句代码的php文件到新建立的网站根目录,然后访问,如下图:

php的zend optimizer

环境已经安装了zend optimizer3.3.3了,达到目的了。不管怎样,宝塔面板里面已经不提示“警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本”了,哈哈。。

《宝塔面板提示【警告:当前为php-fpm模式,将不被Apache2.2支持,请重新安装此PHP版本】怎么办》地址:www.cunguer.com/article/367.html,本文来自村姑网,您身边的IT专家 www.cunguer.com,转载请注明出处,您的支持是我们创作的源泉~!